Back to overview
Degraded
Minor Cellular Outage
Mar 18, 2026 at 7:14pm UTC
Affected services
Push Data Ingestion Service
Resolved
Mar 19, 2026 at 12:37pm UTC
All WECs seem to have recovered
Affected services
Updated
Mar 18, 2026 at 10:11pm UTC
Most devices have recovered. We are continuing to work with our cellular provider to determine the root cause.
Affected services
Created
Mar 18, 2026 at 7:14pm UTC
A small number of WECs have dropped offline simultaneously. After internal investigation, we have determined issues with our cellular provider to be the likely cause. We will continue monitoring and post any updates here.
Affected services