Back to overview
Degraded

Ingestion Queue Delays

Mar 16, 2026 at 6:49pm UTC
Affected services
Push Data Ingestion Service

Resolved
Mar 16, 2026 at 6:59pm UTC

This incident has been resolved

Created
Mar 16, 2026 at 6:49pm UTC

Wattch is experiencing a delay in the ingestion pipeline. Customers may see stale data or spurious uplink / device communications alerts generated for their sites. A mitigation has already been applied; we expect the issue to be resolved shortly.