Back to overview
Degraded

Some eGauge Data Temporarily Unavailable

Mar 07 at 02:04pm EST
Affected services
app.wattch.io
Wattch API
Kiosk API
Kiosk API V2

Resolved
Mar 07 at 04:44pm EST

We have applied a fix - all of the affected data should now be visible.

Created
Mar 07 at 02:04pm EST

Some data reported by eGauges on March 6th, 2025, is not currently available. We're working on a fix as quickly as possible.